Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[F] Upgrade 1.1.8 -> 1.4 (problems in upgrade5.php) [R] [C-Michael83]
#1
Hello all,
especially hello to Tikitiki!! (who wrote "upgrade5.php"Smile)

at first, I would like to thank for this new release, I'm pretty happy with the testing board I built up on 03.08 Smile
RESPECT!!

Now I'm playing with the upgrade of my exisiting forums (some backup of course)

As I was too lazy/stupid/busy to upgrade my theme & template before, my users and me agreed to wait until this release to upgrade our 1.1.8.

Tonight I ran the upgrade, running into different _little_ errors, and some heavy Sad

To fix two typos in upgrade5.php search for:
groupleaders DROP gcanmanagemembers
change to
groupleaders DROP canmanagemembers
and

$db->drop_table("searhlog");
change to
$db->drop_table("searchlog");

I didn't find any results mentioning this errors, so I believe that nobody upgrades from that old installations Smile

Other Errors:

Instead of writing the correct config.php, the script is writing 'Array' instead of my real database entry. I know where it does this, but I cant correct it and I don't understand why Sad
(upgrade.php, line 25-36 my database entry formerly looked like "usr_web69_4)

Then, I get the last error, which is pretty critical, I guess:
in step "Rebuilding Last Post Columns" I get
Fatal error: Call to undefined function: rebuild_thread_counters() in /var/www/web69/html/frmtst/BCKP/install/resources/upgrade5.php on line 558

So we need this function, but where to get from?

EDIT: I downloaded all releases, tried to change "rebuild_thread_counters" to "update_thread_counts"
The funny thing is, until 1.2.6, the function is called "update_thread_count" then it's changed to "update_thread_counters" by Tikitiki in 1.2.7. 1.4 this function is called "rebuild_thread_counters" - you already know that, don't you? Big Grin
As I did a working upgrade to 1.2.4* this night, I guess, there is some work to do afterwards. ...

[*] EDIT 28.11.2008 - I don't remember, but this should be 1.2.6, because 1.2.4 doesn't work.

Ok, thats it till now, could anybody please help me?

Sure, I guess, we could do a upgrade through 1.2.4, but the script already is in the "install folder" od 1.4, so I should get it to work, I'd be happy to help here.

thanks in advance,
I really appreciate your help!

FraGe
hmmm, after searching, I found "rebuild_thread_counters" in differnet files, including it to upgrade5.php didn't help me out Sad
#2
I fixed all three of your errors. Not sure how those got missed. Thanks for reporting the issues.


Attached Files
.php   upgrade5.php (Size: 24.44 KB / Downloads: 222)
#3
Wow, thanks, this was fast Smile
No problem, glad to help, so this changes are going to be in the package soon?
There is still this other problem with the "database <-> Array" when config.php is written.
(Described it before. I' absolutely no clue, how this happen)

Then, when everything is done, the Script should shut down, isn't it?

But it's hanging again @:
Quote:Performing Queries
Performing necessary upgrade queries..

Does this help you?
#4
Hello Ryan,

I hope to have more time now, when I wrote this, it was some hours before my holidays, later I had absolutely no time to do researches on upgrading my forum.

Right now I'm trying to upgrade my 1.1.8 to 1.4.4 - the same errors occur, but I will try to help - so that you could help me out Smile

I am setting up a fresh 1.1.8 Board and will try the upgrade right now - then I'll post the errors.

Hope to get some help here, I have some time to hack around during the next weeks Smile

Thanks in advance for your help,
FraGe
ok, I can't remember exactly, but it seems not to be the same error as when I upgraded to 1.4.0 in August:
Quote:Fatal error: [SQL] [1044] Access denied for user 'web69'@'localhost' to database 'Array'
[READ] Unable to select database in /var/www/web69/html/k4um/frmtst/v144/inc/db_mysql.php on line 548
Fatal error: [SQL] [1046] No database selected
SELECT title,cache FROM datacache in /var/www/web69/html/k4um/frmtst/v144/inc/db_mysql.php on line 548

in the step before, config.php isn't written correctly, the routine writes
$config['database'] = 'Array';
into config.php.

Any Idea how to solve this?

When I do a workaround I get a step further, but then the upgrade hangs at "Upgraderoutine -> Performing necessary upgrade queries.."

... so far...
#5
If you make the following changes the upgrade routine is working fine.

upgrade5.php, search for:
\$config['database'] = '{$config['database']}';
Replace with:
\$config['database'] = '{$config['database']['database']}';

upgrade8.php, search for:
if($db->field_exists('oldadditionalgroups', TABLE_PREFIX."banned"))
Replace with:
if($db->field_exists('oldadditionalgroups', "banned"))
Search for:
if($db->field_exists('olddisplaygroup', TABLE_PREFIX."banned"))
Replace with:
if($db->field_exists('olddisplaygroup', "banned"))

upgrade.php, search for:
isdefault int(1) NOT NULL default '',
Replace with:
isdefault int(1) NOT NULL default '0',

Tested scenarios with the mentioned changes:
  1. 1.2.14 -> 1.4.4: Everything seems to be ok
  2. 1.1.8 -> 1.4.4: Upgrade routine is working fine now but after the upgrade there's no theme
Greets,
Michael
-------------
[Image: donation_drive_sig.png]
#6
Thanks a lot Michael,

Ta any Upgrader with the same problems:
To get a standard theme you could install a new 1.4, export the relevant tables and import them in your board. OR you use Michaels (thanks again Smile) zip file (attached to this post).

Happy working Smile
.zip   mybb.zip (Size: 62.4 KB / Downloads: 240)
#7
(11-29-2008, 01:41 PM)Michael83 Wrote: 1.1.8 -> 1.4.4: Upgrade routine is working fine now but after the upgrade there's no theme

Yes, because of the amount of changes in 1.2, themes were reverted
#8
This was the reason, why I never upgraded to 1.2 - I was to lazy, to rebuild my theme Big Grin
#9
Thank you for your bug report.

This bug has been fixed in our internal code repository. Please note that the problem will not be fixed here until these forums are updated.

With regards,
MyBB Group
#10
Hello,

I'm finally on my way to the upgrade. Had to setup a local Server dump the DB and install both, the old and new Version. Downloading the Versions I realized, that Michaels patches were not integrated in the New Version. I guess nobody is interested in this upgrade anyway, but just in case .... , I would update the files.
(http://community.mybboard.net/thread-350...#pid277231)

upgrade.php, upgrade5.php and upgrade8.php

The most important part is in upgrade5.php.

Thanks a lot,
FraGe

btw: my upgrade process will run the whole night long I guess Sad
Still doing the first view lines *argh*


Forum Jump:


Users browsing this thread: 1 Guest(s)