Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[F] SMTP error / umlaut problem [C-Michael83]
#1
1. If a user sends an email to another user you get this error if you're sending mails through smtp:
Quote:The mail server does not understand the MAIL FROM command
All other mailings are working fine.

2. If the subject of an email contains an umlaut it gets messed up.

Subject: Schönes Wochenende
What you get: =?utf-8?B?U2Now7ZuZXMgV29jaGVuZW5kZSE=?=


Attached Files Thumbnail(s)
   
Greets,
Michael
-------------
[Image: donation_drive_sig.png]
#2
Quote:2. If the subject of an email contains an umlaut it gets messed up.

Subject: Schönes Wochenende
What you get: =?utf-8?B?U2Now7ZuZXMgV29jaGVuZW5kZSE=?=
Is it just in the logs that they appear broken or in the actual receiving mail clients too?
#3
(09-27-2008, 05:02 AM)Chris Boulton Wrote: Is it just in the logs that they appear broken or in the actual receiving mail clients too?
It's broken in both, logs and mails.
Greets,
Michael
-------------
[Image: donation_drive_sig.png]
#4
This user has been denied support. This user has been denied support.
1. "The mail server does not understand the MAIL FROM command" can be caused by bad SMTP settings.

A common cause for the issue is: MyBB/PHP/SMTP/Whatever does not like @ in SMTP user names yet many hosts give user names like [email protected] Usually user%domain.tld can be used instead to avoid the problem. I'm not acquainted with PHP/SMTP well enough to tell if MyBB could do anything to improve this. If % for @ is a standard then MyBB could do the replacement automatically but I don't know if it actually is. At the very least a warning could probably added to the username setting description, several stand alone SMTP clients also warn about possible issues with the @ character in SMTP usernames.

2. is perfectly fine, =?utf-8?B?U2Now7ZuZXMgV29jaGVuZW5kZSE=?= is a correct encoded representation of "Schönes Wochenende!" in a mail header. It has to be done in such a cumbersome way because mail headers are restricted to ASCII characters. UTF-8 characters are only allowed in the mail body. That encoded strings turn up in the error log is a problem with optical representation but unrelated to problem with actually sending mails.

In my forum it took more than just a bit of fiddling with SMTP settings to get it right (however SMTP is hard to set up correctly everywhere) however once I had it right no more errors occured. Ironically even though sending mails by SMTP should be more reliable than PHP mail, mail delivery over SMTP takes several minutes for me, whereas PHP mail get delivered almost instantly. However this may be an issue with my SMTP server.
#5
Hm, Michael is this still reproducible? Can you make the problem with the log email title with SMTP emails a separate bug report since those are essentially two different issues?

frostschutz, so you're suggesting we should replace the @ with % in email addresses when sending with SMTP? Is this something all SMTP servers handle fine with? Or are you suggesting just posting a warning or message on the settings description regarding the @ or %?

Lastly, do you have any online resources that explain the reasoning behind these?
#6
This user has been denied support. This user has been denied support.
Scratch the % for @ suggestion. I don't remember where I read about it.
#7
(01-22-2009, 06:54 PM)Ryan Gordon Wrote: Hm, Michael is this still reproducible?
I never had these problems. They were reported by two users in the german community. I'll ask them if it still happens.
Greets,
Michael
-------------
[Image: donation_drive_sig.png]
#8
Have they responded? I can't really proceed on this bug report unless I am actually able to get debug access to a forum where this happens
#9
Yes, they have. The 2nd issue seems to be resolved. I asked the user with the other problem for access data to a test installation. As soon as I know more you'll know.
Greets,
Michael
-------------
[Image: donation_drive_sig.png]
#10
Doing some further debugging. I retrieved the following response when sending MAIL FROM:<*******@***.de> to the SMTP server (I asterisked out the email addr)

Quote:550 5.7.0 Sender address does not belong to logged in user {mp001}

So this is a security setting on the hosts end to prevent spam. Not a MyBB bug. There really isn't a bug here except for displaying the utf8 title correctly on the mail log and getting a better reason. This bug will only be fixed for the two issues I just listed.


Forum Jump:


Users browsing this thread: 1 Guest(s)