Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[F] small textbox (+ fix)
#1
http://forum.kde.org/showthread.php?tid=6433

Cheers,
Rob
#2
What exactly is the fix? Styling message_new and message_old?
#3
To be honest: I don't know...
I only posted this message; Neverendingo implemented the fix, but he forgot to post it here.

I'll send him here.
#4
Yes, the trick was to style #message_new and #message_old for the original width and height.
And they were 314px height and 591px width.
This fix only applies for konqueror, as most of the other browsers seem to work already.
forum.kde.org
Communicate.
#5
Thanks

(10-14-2008, 11:07 PM)neverendingo Wrote: This fix only applies for konqueror, as most of the other browsers seem to work already.

Okay, but implementing it in the CSS doesn't mess up any other browsers as far as your able to tell?

I'd assume it wouldn't but you can never be too sure
#6
(10-14-2008, 11:10 PM)Ryan Gordon Wrote: Thanks

(10-14-2008, 11:07 PM)neverendingo Wrote: This fix only applies for konqueror, as most of the other browsers seem to work already.

Okay, but implementing it in the CSS doesn't mess up any other browsers as far as your able to tell?

I'd assume it wouldn't but you can never be too sure
it seems it doesn't mess up other browsers.
But a user of our board told us a nicer solution, i will quote him:

Quote:I just recommended the CSS because I thought it is the easiest for the KDE forums, without fiddling with the JS and trying it out in all browsers.
I cannot try it at the moment, but usually the right fix would be to modify editor.js so it sets the "cols" and "rows" attribute programatically from the values of the existing one. So in the part where you do

textInput = document.createElement("textarea");

You should also do

textInput.setAttribute("cols", oldTextbox.getAttribute("cols"));

and the same for the rows.
I will try that first at my local copy, but i guess he is right, as i see that one of the message boxes has no attributes like that at all.
forum.kde.org
Communicate.
#7
Thank you for your bug report.

This bug has been fixed in our internal code repository. Please note that the problem will not be fixed here until these forums are updated.

With regards,
MyBB Group


Forum Jump:


Users browsing this thread: 1 Guest(s)