Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[F] MyBB upgrade 1.4.3 -> 1.4.4 - problems with PostgreSQL
#1
The problems lie in install/upgrade.php and install/resources/upgrade14.php (and I suppose there similar bugs in many install/resources/upgrade*.php).

It's all about queries which are send to PostgreSQL database and are not understood by PSQL. These are:

1. Using "SHOW INDEX FROM <table_name>", which should be replaced with "SELECT indexname FROM pg_indexes WHERE tablename='<table_name>'".

2. Using int(2), int(1), bigint(30), which should be replaced with smallint, smallint (or something other, I am not sure) and bigint (or something even bigger, I think, if possible).

I have modified these files to work with my base. I can send you these if needed.

My suggestion is to revise them and write more "if(db->type == "pgsql")" Smile
MyBB 1.4.4
PHP: 5.2.6-pl7-gentoo
PostgreSQL 8.2.7
#2
(11-30-2008, 02:52 PM)Peter de Sowaro Wrote: The problems lie in install/upgrade.php and install/resources/upgrade14.php (and I suppose there similar bugs in many install/resources/upgrade*.php).

We don't need to support PostgreSQL in anything below upgrade13.php

Thanks for your bug report
#3
Thank you for your bug report.

This bug has been fixed in our internal code repository. Please note that the problem will not be fixed here until these forums are updated.

With regards,
MyBB Group


Forum Jump:


Users browsing this thread: 1 Guest(s)