Not Solved templates iusses
#1
Not Solved
ok;i think that i need a subscription to this forumBig Grin
However i've some visual iusse with mybulletin:
No pm reply key
[Image: th_02530_1_122_372lo.jpg]
Layout problem
[Image: th_02531_2_122_104lo.jpg]
no subscription options
[Image: th_02534_4_122_26lo.jpg]

Someone know the name of the templates for fix it?or better someone know how to fix it?
Reply
#2
Not Solved
I'd suggest contacting the author of the theme and language packs. It seems you have some things missing.

For the subscription options, see the template Post Templates => post_subscription_method. Ensure that $lang->no_subscribe, $lang->no_email_subscribe and $lang->instant_email_subscribe are there in the coding (this is what displays the text). If they are, then it's a problem with the language pack. If not, try reverting the templates.

Go to Configuration => Languages and edit your language pack. Then, edit global.lang.php, and find the variable no_subscribe, no_email_subscribe and instant_email_subscribe. These boxes need to be filled in with the right text for the options to be displayed.

Your layout problem can't be solved easily - it happens even here on the default MyBB theme.

For the PM reply button, edit the Post Bit Templates => postbit_reply_pm. Check that there is the right content here (as compared with the default theme). If not, try and revert the template. If the right coding is there, then the image is missing. Upload the right image to the theme's image directory.

Remember to backup your forum and database before making any changes.

Smile
Reply
#3
Not Solved
This is the wrong forum, there's a themes forum for a reason, theme problems. You'll have to contact the author.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#4
Not Solved
(2008-12-10, 10:20 AM)Tom.M Wrote: I'd suggest contacting the author of the theme and language packs. It seems you have some things missing.
Well the theme isn't support; who use this theme is "alone".Dodgy
(2008-12-10, 10:20 AM)Tom.M Wrote: For the subscription options, see the template Post Templates => post_subscription_method. Ensure that $lang->no_subscribe, $lang->no_email_subscribe and $lang->instant_email_subscribe are there in the coding (this is what displays the text). If they are, then it's a problem with the language pack. If not, try reverting the templates.
Yes they are:
<label><input type="radio" name="postoptions[subscriptionmethod]" {$postoptions_subscriptionmethod_dont} value="" style="vertical-align: middle;" /> {$lang->no_subscribe}</label><br />
	<label><input type="radio" name="postoptions[subscriptionmethod]" {$postoptions_subscriptionmethod_none} value="none" style="vertical-align: middle;" /> {$lang->no_email_subscribe}</label><br />
	<label><input type="radio" name="postoptions[subscriptionmethod]" {$postoptions_subscriptionmethod_instant} value="instant" style="vertical-align: middle;" /> {$lang->instant_email_subscribe}</label><br />
(2008-12-10, 10:20 AM)Tom.M Wrote: Go to Configuration => Languages and edit your language pack.
uhm what i should edit?
(2008-12-10, 10:20 AM)Tom.M Wrote: Then, edit global.lang.php, and find the variable no_subscribe, no_email_subscribe and instant_email_subscribe. These boxes need to be filled in with the right text for the options to be displayed.

Your layout problem can't be solved easily - it happens even here on the default MyBB theme.

For the PM reply button, edit the Post Bit Templates => postbit_reply_pm. Check that there is the right content here (as compared with the default theme). If not, try and revert the template. If the right coding is there, then the image is missing. Upload the right image to the theme's image directory.
this is weird; the code is right:
<a href="private.php?action=send&amp;pmid={$id}&amp;do=reply"><img src="{$theme['imglangdir']}/pm_reply.gif" alt="{$lang->reply}" title="{$lang->reply_title}" /></a>
and the image is also into: /forum/images/mybulletin/languagepack/pm_reply.gif
but nothing apperas.

Thanks.

(2008-12-10, 10:21 AM)Matt_ Wrote: This is the wrong forum, there's a themes forum for a reason, theme problems. You'll have to contact the author.

Right;i send an advice to move the thWink
Reply
#5
Not Solved
(2008-12-10, 11:44 AM)microcip Wrote: uhm what i should edit?

Edit your language pack then...
(2008-12-10, 10:20 AM)Tom.M Wrote: ...edit global.lang.php, and find the variable no_subscribe, no_email_subscribe and instant_email_subscribe. These boxes need to be filled in with the right text for the options to be displayed.

(2008-12-10, 11:44 AM)microcip Wrote: ...the image is also into: /forum/images/mybulletin/languagepack/pm_reply.gif but nothing apperas.

My guess is that the image is actually in /forum/images/mybulletin/pm_reply.gif...
Reply
#6
Not Solved
(2008-12-10, 12:08 PM)Tom.M Wrote: Edit your language pack then...
...edit global.lang.php, and find the variable no_subscribe, no_email_subscribe and instant_email_subscribe. These boxes need to be filled in with the right text for the options to be displayed.
Well but i don't have it:
original/english:
[Image: th_20081210141233_english.jpg]
Italian:
[Image: th_20081210141144_italian.jpg]
it's my fault?Confused

(2008-12-10, 12:08 PM)Tom.M Wrote: My guess is that the image is actually in /forum/images/mybulletin/pm_reply.gif...
uhm, i think that isn't a url problem i've try also to change the code into:
<a href="private.php?action=send&amp;pmid={$id}&amp;do=reply"><img src="http://www.mywebsite.com/forum/images/MyBulletin/italiano/pm_reply.gif" alt="{$lang->reply}" title="{$lang->reply_title}" /></a>
to force it but nothing appear.
Reply
#7
Not Solved
Have you tried looking through your images folders to see if the pm_reply button is actually there?! If it isn't, you'll need to upload one...

It's not really your fault. Edit ./inc/languages/{your language pack}/global.lang.php, and find:

$l['no_post_icon']

After this should be:

$l['thread_subscription_method'] = "<strong>Thread Subscription:</strong><br /><span class=\"smalltext\">Specify the type of email notification and thread subscription you'd like to have to this thread. (Registered users only)</span>";
$l['no_subscribe'] = "Do not subscribe to this thread";
$l['no_email_subscribe'] = "Subscribe without receiving email notification of new replies";
$l['instant_email_subscribe'] = "Subscribe and receive email notification of new replies";

If not, add them in, and then translate them to your requirements...
Reply
#8
Not Solved
(2008-12-10, 02:26 PM)Tom.M Wrote: Have you tried looking through your images folders to see if the pm_reply button is actually there?! If it isn't, you'll need to upload one...
Yes sure;was the first thing that i've do:
[Image: immaginebf9.th.jpg]
(2008-12-10, 02:26 PM)Tom.M Wrote: It's not really your fault. Edit ./inc/languages/{your language pack}/global.lang.php, and find:

$l['no_post_icon']

After this should be:

$l['thread_subscription_method'] = "<strong>Thread Subscription:</strong><br /><span class=\"smalltext\">Specify the type of email notification and thread subscription you'd like to have to this thread. (Registered users only)</span>";
$l['no_subscribe'] = "Do not subscribe to this thread";
$l['no_email_subscribe'] = "Subscribe without receiving email notification of new replies";
$l['instant_email_subscribe'] = "Subscribe and receive email notification of new replies";

If not, add them in, and then translate them to your requirements...
Oh;finally this work.
THX!
Reply
#9
Not Solved
ok;i've figured out why i don't have the reply pm button and others.
I don't have them in to the code...
My code:
<!-- Buttons-->

<table width="100%" border="0" cellpadding="0" cellspacing="0">
	<tr>
		<td align="left"><!-- start: postbit_email -->
<a href="member.php?action=emailuser&amp;uid=53"><img src="images/MyBulletin/italiano/postbit_email.gif" alt="Invia una e-mail a questo utente" title="Invia una e-mail a questo utente" /></a>

<!-- end: postbit_email --><!-- start: postbit_pm -->
<a href="private.php?action=send&amp;uid=53"><img src="images/MyBulletin/italiano/postbit_pm.gif" alt="Invia un messaggio privato a questo utente" title="Invia un messaggio privato a questo utente" /></a>
<!-- end: postbit_pm --><!-- start: postbit_find -->
<a href="search.php?action=finduser&amp;uid=53"><img src="images/MyBulletin/italiano/postbit_find.gif" alt="Trova tutti i messaggi di questo utente" title="Trova tutti i messaggi di questo utente" /></a>
<!-- end: postbit_find --></td>
		<td align="right"><span class="smalltext"></span></td>
	</tr>
	</table>
</td>
</tr>
</table>

default code:
<tr>
			<td class="trow1 post_buttons ">
				<div class="author_buttons float_left">
					<!-- start: postbit_pm -->
<a href="private.php?action=send&amp;uid=2"><img src="images/italiano/postbit_pm.gif" alt="Invia un messaggio privato a questo utente" title="Invia un messaggio privato a questo utente" /></a>
<!-- end: postbit_pm --><!-- start: postbit_find -->

<a href="search.php?action=finduser&amp;uid=2"><img src="images/italiano/postbit_find.gif" alt="Trova tutti i messaggi di questo utente" title="Trova tutti i messaggi di questo utente" /></a>
<!-- end: postbit_find -->
				</div>
				<div class="post_management_buttons float_right"><!-- start: postbit_reply_pm -->
<a href="private.php?action=send&amp;pmid=501&amp;do=reply"><img src="images/italiano/pm_reply.gif" alt="Rispondi" title="Rispondi a questo messaggio privato" /></a>
<!-- end: postbit_reply_pm --><!-- start: postbit_forward_pm -->
<a href="private.php?action=send&amp;pmid=501&amp;do=forward"><img src="images/italiano/pm_forward.gif" alt="Inoltra" title="Inoltra questo messaggio privato ad un altro utente" /></a>
<!-- end: postbit_forward_pm --><!-- start: postbit_delete_pm -->
<a href="private.php?action=delete&amp;pmid=501&amp;my_post_key=a68b5aed2297452339afee04445f9e1a"><img src="images/italiano/pm_delete.gif" alt="Cancella" title="Cancella questo messaggio privato" /></a>
<!-- end: postbit_delete_pm -->
				</div>
			</td>
		</tr>

	</tbody>
</table>

where i can edit that themplate?
Reply
#10
Not Solved
postbit and postbit_classic
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)