Thread Rating:
  • 8 Vote(s) - 3.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Condition and vbnavbar for 1.4.14
#21
@Ori: Thanks for the heads up. I have to admit I quite forgot about testing in Google Chrome. Glad that the vbnavbar code seems to be 'future proof' for IE8 (apparently the "two password boxes on the same page registration problem" is resolved in IE8 as well) and works ok in Chrome. I actually checked out the cookie settings for my forum and noticed that mine is just at '/' so it's a big phew for me after reading your solution. Smile
Current motto: Cross referencing threads by providing links is a good idea!
Back-on Online - Back-on Fansite
http://www.backon-online.com/

WordPress Snippets
http://www.wpsnippets.com/
Reply
#22
You should know that this is ONLY a Google Chrome problem and, actually, the default settings in MyBB ('/forum/') should be preferred as it solves other problems (mostly, in Linux based desktops and as such, also MAC OS 10.?). You can find questions/help requests from time to time in the 'General Support' forum on this site.

Ori...
Of two equivalent theories or explanations, all other things being equal, the simpler one is to be preferred.
simplified translation of Occam's razor

[Image: 82pwtx]
Reply
#23
One of the files is called function.php, but I already have a file called that in my inc folder. Would changing the name of this plugins function.php make it not work?
Reply
#24
I suggest that you rename the 'function.php' file you have in the './inc' folder (so that if anything goes wrong, you have a backup), but, in any case, the 'function.php' file that's in the zip file is a 1.4.4 file (as much as I saw - flick, correct me if I'm wrong) with some added code to get the bar working.

Ori...
Of two equivalent theories or explanations, all other things being equal, the simpler one is to be preferred.
simplified translation of Occam's razor

[Image: 82pwtx]
Reply
#25
@bombbob: As okitai said, the functions.php file is pretty much the functions.php file from 1.4.4 with a couple of extra lines at the start. You can always download the original file again and just replace the functions.php if anything goes wrong.
Current motto: Cross referencing threads by providing links is a good idea!
Back-on Online - Back-on Fansite
http://www.backon-online.com/

WordPress Snippets
http://www.wpsnippets.com/
Reply
#26
Yes. I tried renaming the functions.php file that was already in my inc folder, and my site wouldn't load. It came up:

Fatal error: Call to undefined function my_strpos() in /home/bombbob/public_html/bb/Upload/inc/class_error.php on line 169

Any suggestions what to do? Also, does this mod work with afresh?

Cheers.
Reply
#27
Did you rename your "original" file (the one already in the './inc' folder) and copied the one on the first post before loading you site - the 'functions.php' file is needed by MyBB system. A 'functions.php' file has to be in the './inc' folder - either the original MyBB's one or the vbnavbar modified one.
Another thing to be sure about: is you forum at least version 1.4.2 (if I remember correctly, there was a major change in the 'functions.php' from version 1.4.0 to the 1.4.2) - I do recommend to load the vbnavbar on version 1.4.4 as this is the files that flick used as a base for the changes needed by the vbnavbar.


Ori...
Of two equivalent theories or explanations, all other things being equal, the simpler one is to be preferred.
simplified translation of Occam's razor

[Image: 82pwtx]
Reply
#28
I really don't think I need to add any more detail to okitai's helpful reply Smile Thanks!
Current motto: Cross referencing threads by providing links is a good idea!
Back-on Online - Back-on Fansite
http://www.backon-online.com/

WordPress Snippets
http://www.wpsnippets.com/
Reply
#29
Hi,

I added it to my forum (See Signature) and the following problems are:

The guest menu looks wrong... There are numbers instead of whats in the lang files and there is private messages link on it.

Welcome back, {1}. You blessed us with your presence last: {2}
Secret Messages (Unread {1}, Total {2})
What's the time Mr Wolf?: 05-02-2009, 12:48 AM

On the member area the drop down menu for the User CP doesn't work and also the login menu is still present.

Search drop down menu works though.

Any help?
Reply
#30
@Luke Beale: Thanks for your feedback. With regards to the drop down, there seems to be a small problem directly copying-pasting sometimes from the code provided on the Forums to the template editor, which results in random blank spaces that affect the dropdown menu.

Would it be possible to try pasting the code into a text editor first before copying it into the template editor please?

As for the other question: I believe this is the correct solution (see original post) which I'll write here as well for future reference:

Quote:If anyone has had issues with the 'if condition' not working (where even guests can see the "Private messages" and a string of nonsense) - with (complete) reference to this thread:

Find
$template = str_replace("\\'", "'", addslashes($template));


in inc/class_templates.php (around Line 114) and replace with

$template = str_replace("\\'", "'", addslashes($template));
$template= str_replace("<if condition=","\".iif(",$template);
$template= str_replace("<then>",",\"",$template);
$template= str_replace("<else />","\",\"",$template);
$template= str_replace("</if>","\").\"",$template);
Current motto: Cross referencing threads by providing links is a good idea!
Back-on Online - Back-on Fansite
http://www.backon-online.com/

WordPress Snippets
http://www.wpsnippets.com/
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)