Solved: 9 Years, 11 Months, 2 Weeks ago X-Cache Settings
#1
Solved: 9 Years, 11 Months, 2 Weeks ago
Does MyBB utilize the X-Cache variable cache, or should that be disabled?
Thanks for your help.
#2
Solved: 9 Years, 11 Months, 2 Weeks ago
I don't even know what that is, but I'm guessing no.
#3
Solved: 9 Years, 11 Months, 2 Weeks ago
Check inc/config.php

Replace:
$config['cache_store'] = 'db';
with
$config['cache_store'] = 'xcache';
#4
Solved: 9 Years, 11 Months, 2 Weeks ago
got this error while activating xcache Smile


Attached Files Thumbnail(s)
   
Hello, Welcome to MyBB Indonesia to get local support
My 'Simple' Unique Plugin here Smile
#5
Solved: 9 Years, 11 Months, 2 Weeks ago
FBI, it looks like you need to enable the variable cache by editing the x-cache config file and setting xcache.var_size to something greater than 0.
#6
Solved: 9 Years, 11 Months, 2 Weeks ago
Thanks,
I grab from this.
And add this to PHP.INI
[xcache-common]
;; install as zend extension (recommended), normally "$extension_dir/xcache.so"
zend_extension = /usr/local/lib/php/extensions/no-debug-non-zts-20060613/xcache.so
zend_extension_ts = /usr/local/lib/php/extensions/no-debug-non-zts-20060613/xcache.so
;; For windows users, replace xcache.so with php_xcache.dll
;zend_extension_ts = c:/php/extensions/php_xcache.dll
;; or install as extension, make sure your extension_dir setting is correct
; extension = xcache.so
;; or win32:
; extension = php_xcache.dll

[xcache.admin]
xcache.admin.auth = On
xcache.admin.user = "mOo"
; xcache.admin.pass = md5($your_password)
xcache.admin.pass = ""

[xcache]
xcache.shm_scheme =        "mmap"
xcache.size  =               60M
xcache.count =                 1
xcache.slots =                8K
xcache.ttl   =              3600
xcache.gc_interval =         300

; Same as aboves but for variable cache
; If you don't know for sure that you need this, you probably don't
xcache.var_size  =            4M
xcache.var_count =             1
xcache.var_slots =            8K
xcache.var_ttl   =             0
xcache.var_maxttl   =          0
xcache.var_gc_interval =     300

; N/A for /dev/zero
xcache.readonly_protection = Off

xcache.mmap_path =    "/dev/zero"

xcache.cacher =               On
xcache.stat   =               On

And the restart server ;
shell> /etc/init.d/httpd restart

Done!
Now, going faster Wink
Hello, Welcome to MyBB Indonesia to get local support
My 'Simple' Unique Plugin here Smile
#7
Solved: 9 Years, 11 Months, 2 Weeks ago
Now, tuning X-Cache....

How big the different MyBB PHP script should be cache?
Hello, Welcome to MyBB Indonesia to get local support
My 'Simple' Unique Plugin here Smile


Forum Jump:


Users browsing this thread: 1 Guest(s)