Discuss: MyBB 1.03 Released - Security Update
#11
Hi Chris,

thanks for the update. But there's one problem: The search function does not work:
Quote:mySQL error: 1064
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND p.message LIKE '%test%'OR AND p.subject LIKE '%test%') AND t.fid NOT IN ('1' at line 1
Query: SELECT p.tid FROM posts p, threads t WHERE (1=0 OR AND p.message LIKE '%test%'OR AND p.subject LIKE '%test%') AND t.fid NOT IN ('14','15','16','33')
Greets,
Michael
-------------
[Image: donation_drive_sig.png]
#12
yea, i get this error when trying to search as well.. everything else seems to be working fine, but after submitting a search it sends out that error on a plain white page. and my forums search worked just before i updated.


/edit- just tried to search on this forum and it did the same thing Toungue
#13
same here!

mySQL error: 1064
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND p.message LIKE '%tech%'OR AND p.subject LIKE '%tech%')' at line 1
Query: SELECT p.tid FROM mybb_posts p, mybb_threads t WHERE (1=0 OR AND p.message LIKE '%tech%'OR AND p.subject LIKE '%tech%')
#14
Quote:mySQL error: 1064
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND p.message LIKE '%tech%'OR AND p.subject LIKE '%tech%')' at line 1
Query: SELECT p.tid FROM mybb_posts p, mybb_threads t WHERE (1=0 OR AND p.message LIKE '%tech%'OR AND p.subject LIKE '%tech%')

there's a fix here: http://community.mybboard.net/showthread...n=lastpost

----
Thanks for the update. applyed Smile.

#15
awesome!
thanx very much.
keep up the good work!
#16
Regarding the fix
however it was a part of the fix, but it seems u will have to do it Smile


regards
#17
I'm having trouble with logging in since the upgrade. Yes I've cleared my cookies but I still have to keep logging in it seems my session have timed out.
Not sure why but even clearing my cookies requires me to login a few times before it remembers me.
Updated Site!
My mods
1.1: MyBB Zip Installer, Easy Install v2.0, Cash/Points plugin, PayPal/Subscriber, Reply by email, Advanced Plugins
#18
going to install patch when I get out of school Smile
#19
Installed, and applied the search fix. Thanks guys Smile
#20
http://community.mybboard.net/showthread...1#pid38921

this I can not find in the search.php at all


Forum Jump:


Users browsing this thread: 1 Guest(s)