Thread Rating:
  • 23 Vote(s) - 3.3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Updating your Plugins to 1.8? PLEASE READ
#1
Hi All,

After several questions I've decided to make a sticky on this. When upgrading to 1.8 you first need to consider if your plugins are compatible.

You have two options here:
  1. Wait for the plugin author to update them.
  2. Or update them yourself.
If you want to go with the second option you will need to delve into the plugins code and change some things around. Firstly you will need to change it's compatibility indicator you can do this by changing:
PHP Code:
"compatibility" => "16*"
to
PHP Code:
"compatibility" => "18*"
which is inside the function 'pluginname_info'.

If the compatibility indicator isn't there or is just '*' then your plugin will work fine without changes so long as you aren't having problems with mod_security. (See below if you are).

Note that this will not be enough for every single plugin.

Also if you are having problems with mod_security on your forum you will need to find and change any admin url's using the old format (config/settings). All you have to do here is change the '/' to a '-'.

If you still have problems after this then you will need to contact the plugin author. It may be that it uses an old database field or something which has changed in 1.8. But for most plugins you only need to change one or two things to make it work properly. Smile
Thanks, Polarbear541


Forum Jump:


Users browsing this thread: 1 Guest(s)