Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 9 Years, 6 Months ago Wrong Symbol Problem
#1
Solved: 9 Years, 6 Months ago
The ' is appearing as â in my database in the posts from a merge. What would be the proper database query to replace all â in the posts with '?
Also, I am having a bunch of other problems. I imagine I will post them all. I almost have that first one solved by downloading the file and replacing all. :p Which is pretty easy.

The next problem is that in threads, when they reach the last post on a page they add an extra page that has no posts, and when you click on it it shows a "does not exist" error. Any clues?

When I try to search, only sometimes though, I get this error
MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1054 - Unknown column 'Array' in 'where clause'
Query:
SELECT pid, tid FROM mybb_posts WHERE pid IN(Array) AND visible=1 ORDER BY dateline DESC

And last for now(there was a couple more but I cannot duplicate them again for some reason), when I click on the whose online list I get this message.
Access denied for user 'setonwr1'@'localhost' (using password: NO)

I converted from phpbb3, if you need that info. Also, I would be willing to send staff info on the site(it's a closed site) via pm if they need it and a login.
#2
Solved: 9 Years, 6 Months ago
When viewing some profiles I also get this warning at the top of the page.

The following warnings occurred:
Warning [2] mktime() expects parameter 4 to be long, string given - Line: 1467 - File: member.php PHP 5.2.9 (Linux)
File	Line	Function
[PHP]	 	errorHandler->error
/member.php	1467	mktime
#3
Solved: 9 Years, 6 Months ago
Look this.
#4
Solved: 9 Years, 6 Months ago
That seems to have fixed that one error. Thanks. Now for the rest. Toungue
#5
Solved: 9 Years, 6 Months ago
Your last error is database related. Is the info you put in config.php corrent and did you rename config.default.php to config.php?? Using Password: NO means there's no password.
No PM support
My YouTube
#6
Solved: 9 Years, 6 Months ago
But then it would happen to the whole forum would it not? I will take a look at the config when I get the chance and make sure it is all good. But it seems strange that everything else would be working but that one function.


Forum Jump:


Users browsing this thread: 1 Guest(s)