Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved Merge System 1.6 and SMF 1.1 attachments problem.
#31
Not Solved
(09-28-2010, 07:51 PM)CaptOblivious Wrote: Wow, I had been under the impressions that mime_content_type actually looked at the file's contents, and so needed a full path. My mistake!

I see you already updated the bug report, so I'll leave it at that.

Yeah, I updated it and fixed it Smile Thanks for reporting it though.

Quote:And my apologies if I appear impatient. It is a little hard to tell what has been omitted by mistake (i.e., mixed entries in the attachments table), and what has been omitted by choice (i.e., avatars haven't been completed yet) in the merge system, so I naturally assume the least possible charitable interpretation…I'll not do that going forward Big Grin

No harm, and it was purely oversight on my part to not consider mixed installs from upgrades.

Avatars aren't going to be included in the Merge System for now. I'm planning on Adding them in at a later time. But for now the goal is to make this branch as stable as possible before implementing new features. It is something I want, but priorities need to be considered.
#32
Not Solved
What about the post ID issue, wherein attachments get attached to the wrong post? I tried tracing the functions responsible for determining the new post ID from the old post ID, but there's a lot going on in there for me to follow. Is there anything I can do to help debug this issue?
#33
Not Solved
Not really, nor can I duplicate it right now, it may come from something incorrect you're doing.

Also, your hack with the filename is incorrect as well, it works perfectly the way it is for me. What are you putting for your path? For me it works fine with both absolute, relative, and URL for paths.
#34
Not Solved
(09-28-2010, 08:16 PM)Dylan M. Wrote: Not really, nor can I duplicate it right now, it may come from something incorrect you're doing.

Also, your hack with the filename is incorrect as well, it works perfectly the way it is for me. What are you putting for your path? For me it works fine with both absolute, relative, and URL for paths.

Which hack? I'm using absolute filenames for the path.

#35
Not Solved
The one where you return from get_raw_filename() with / prepended to it. Big Grin

And ok, absolute PATH with or without the trailing slash, if you let the Merge System place a value for you it will always have a trailing slash already on it.

However, you're right in that the code should check to make sure there is a trailing slash and place one if there is not. Just the way you're doing it is improper.
#36
Not Solved
(08-12-2010, 01:49 PM)Dylan M. Wrote: Well, you shouldn't have to though Smile

They should be detected by the Merge System.


I also think so.thanks


__________________
watch free movies online
#37
Not Solved
Ok, what CaptOblivious was trying to say about appending / between the PATH provided and the filename, and which I said should be detected automatically by the Merge System, in point of fact already is (I suspected this, but only just now had the time to verify it)

From convert/resources/modules/attachments.php:
		if($mybb->input['uploadspath'])

		{

			$import_session['uploadspath'] = $mybb->input['uploadspath'];

			if(substr($import_session['uploadspath'], strlen($import_session['uploadspath'])-1, 1) != '/') 

			{

				$import_session['uploadspath'] .= '/';

			}

		}

So it is a moot point.
#38
Not Solved
This should be good now, if those involved would like to test the latest code from the 1.6 branch in the svn please feel free to do so. Thanks.
#39
Not Solved
Hi! Dylan Smile
Latest 1.6 branche have a Parse error: parse error in C:\wamp\www\mybb\convert\boards\smf\users.php on line 129

---
$insert_data['signature'] = = str_replace (double "=")
#40
Not Solved
Sorry about that, its corrected.


Forum Jump:


Users browsing this thread: 1 Guest(s)