Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
mybb support for X-Forwarded-For
#11
sorry to dig this thread up... after 3 days of panic, it has been resolved.

mod_rpaf & its successor should resolve all of this mess. no need to edit php files or anything.

i put mybb behind varnish, and now its reporting the correct ip addresses, once i enabled mod_rpaf.

i configured varnish default.vcl

backend default {
  .host = "127.0.0.1";
  .port = "8080";
}
sub vcl_recv {
remove req.http.X-Forwarded-For;
set req.http.X-Forwarded-For = client.ip;
}
#12
Of course there is need to edit files as this suggestion has been included for a while now... Wink
[Image: banner.png]


Forum Jump:


Users browsing this thread: 1 Guest(s)