Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 9 Years, 3 Weeks ago What is ?
#1
Solved: 9 Years, 3 Weeks ago
Hi, I used the PHP to retrieve the latest topics but I see this "" to the up.


Site: http://habbocean.altervista.org/

In the box "Ultimi topic".

What can I do for delete this ?
#2
Solved: 9 Years, 3 Weeks ago
http://en.wikipedia.org/wiki/Byte_order_...y_encoding

Make sure you've not got any spaces/characters before the <?php in whatever file you're using to get the latest topics.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
#3
Solved: 9 Years, 3 Weeks ago
Thanks for answering.

I used this code:
<?php
$limit = 10;
//$forumpath = '/';

define("IN_MYBB", 1);
require('global.php');

$unviewable = get_unviewable_forums(true);

if($unviewable)
{
$unview = "AND fid NOT IN ({$unviewable})";
}

$query = $db->simple_select('threads', '*', "1=1 {$unview} ORDER BY tid DESC LIMIT {$limit}");
if($db->num_rows($query) > 0)
{
while($row = $db->fetch_array($query))
{

$date = my_date($mybb->settings['dateformat'], $row['lastpost'], "", 1);
$time = my_date($mybb->settings['timeformat'], $row['lastpost'], "", 1);

if(strlen($row['subject'])>25)
{
$val = substr($row['subject'],0,28)."...";

}
else {
$val= $row['subject'];
}

{
if ($i==1)
{
$i=2;
}
else
{$i=1;
}
}



	echo "<tr class=\"trow$i\"><td width=\"1%\" align=\"center\"><img src=\"http://www.habbocean.altervista.org/images/icons/topic.gif\"></td>
<td width=\"32%\"><a
href=\"http://www.habbocean.altervista.org/forum/showthread.php?tid={$row['tid']}\" target=\"_blank\">{$val}</a></td>
<td width=\"10%\" align=\"center\">{$row['replies']}</td>
<td width=\"10%\" align=\"center\">{$row['views']}</td>
<td width=\"18%\"><a href=\"http://www.habbocean.altervista.org/forum/member.php?action=profile&username={$row['lastposter']}\" style=\"font-size: 11px;\">{$row['lastposter']}</a></td></tr>";
}
}
else
{
echo '<font style="font-size: 11px; font-family:verdana, sans-serif;"><b>Nessuna nuovo topic.</b></font>';
}
?>

What's wrong?

#4
Solved: 9 Years, 3 Weeks ago
What text editor are you using?? If it's Notepad it'll be that, use Wordpad or another text editor.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
#5
Solved: 9 Years, 3 Weeks ago
I used Altervista's text-editor, it's my hosting.

1 Week ago was ok ç_ç

I don't know what's the problem...
#6
Solved: 9 Years, 3 Weeks ago
1. Download and install Notepad++.
2. Copy and paste your code into Notepad++.
3. Go to Encoding > Encode in UTF-8 without BOM.
4. Save, upload and overwrite the file to your server.

Seems to work for me. And like Matt said, make sure there's nothing before the <?php tag.
#7
Solved: 9 Years, 3 Weeks ago
Uhmm... nothing.. but if we go here: http://habbocean.altervista.org/forum/topic.php we don't see "" ._.

Is a global.php's problem?
#8
Solved: 9 Years, 3 Weeks ago
Go to AdminCP -> Tools & Maintenance -> File Verification.

What does it say??
#9
Solved: 9 Years, 3 Weeks ago
Where is "File Verification"? I don't see it °-°
#10
Solved: 9 Years, 3 Weeks ago
Are you even running MyBB 1.6? It seems to me you're still on 1.4.

Try running this plugin, which does the same as File Verification: http://community.mybb.com/thread-47354-p...#pid347635 (for 1.4)


Forum Jump:


Users browsing this thread: 1 Guest(s)