Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 7 Years, 7 Months, 3 Weeks ago "Authorization code mismatch." Subcribing to forums.
#1
Solved: 7 Years, 7 Months, 3 Weeks ago
Just ran into an issue when subscribing to a forum. All forums product the same message.

I get the error code:

Authorization code mismatch. Are you accessing this function correctly? Please go back and try again.

1.6.1
www.DoubleDasher.com

Let me know if you need a test account.

Thanks
#2
Solved: 7 Years, 7 Months, 3 Weeks ago
Your forumdisplay_threadlist template won't be default. Yours will have:

Code:
<a href="usercp2.php?action={$add_remove_subscription}subscription&amp;type=forum&amp;fid={$fid}">{$add_remove_subscription_text}</a>

it should be:

Code:
<a href="usercp2.php?action={$add_remove_subscription}subscription&amp;type=forum&amp;fid={$fid}&amp;my_post_key={$mybb->post_code}">{$add_remove_subscription_text}</a>
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
#3
Solved: 7 Years, 7 Months, 3 Weeks ago
Cool. That was easy..

Thanks Matt
#4
Solved: 7 Years, 7 Months, 3 Weeks ago
hi matt, please help, mybb community had also the same problem. I've already checked forumdisplay_threadlist template and its the same as yours. thanks and merry christmas to you!

http://www.pnsers.com
#5
Solved: 7 Years, 7 Months, 3 Weeks ago
Test account??
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
#6
Solved: 7 Years, 7 Months, 3 Weeks ago
Hello Matt,

I made the necessary change (found some duplication and removed it), however, I am still getting the message.

Code:
                <span class="smalltext"><strong><a href="misc.php?action=markread&amp;fid={$fid}">{$lang->markforum_read}</a> |                 <a href="usercp2.php?action={$add_remove_subscription}subscription&amp;type=forum&amp;fid={$fid}&amp;my_post_key={$mybb->post_code}">{$add_remove_subscription_text}</a> {$clearstoredpass} </strong></span>            </div>

Any ideas?
#7
Solved: 7 Years, 7 Months, 3 Weeks ago
Are you sure you're editing the right template set for your theme??
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
#8
Solved: 7 Years, 7 Months, 3 Weeks ago
I am getting the same message. My forumdisplay_threadlist template (non-test account) looks like this:

Code:
<a href="usercp2.php?action={$add_remove_subscription}subscription&amp;type=forum&amp;fid={$fid}&amp;my_post_key={$mybb->post_code}">
{$add_remove_subscription_text}</a>
#9
Solved: 7 Years, 7 Months, 3 Weeks ago
(03-21-2011, 12:06 AM)taylor_smith Wrote: I am getting the same message. My forumdisplay_threadlist template (non-test account) looks like this:

Code:
<a href="usercp2.php?action={$add_remove_subscription}subscription&amp;type=forum&amp;fid={$fid}&amp;my_post_key={$mybb->post_code}">
{$add_remove_subscription_text}</a>

details matter Toungue

Your other thread is about "Subscribe to Threads" this thread is about "Subcribing to forums."
Please look at your showthread template(s)
#
MyBB is the best forum software! Exclamation

#10
Solved: 7 Years, 7 Months, 3 Weeks ago
i got the same problem but different case
i have look at the forumdisplay_threadlist, there were no miss code there..

then i checked again
i got where is the problem
the problem on the showthread template

and it fix now,,
thanks for solution
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)