Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 10 Years, 2 Months ago SQL Error: 1054 - Unknown column 'uid' in 'where clause'
#1
Solved: 10 Years, 2 Months ago
Hello,
thanks for making time for others.

Recently upgraded from 1.411 -> 1.602
Upgrade went smoothly, no errors.

Error: as SuperUser -> login -> Admin cp -> Dashboard ->

See 2 users Awaiting Activation ->

click on Awaiting Activation ->

Lists 2 users

Click on options -> scroll to delete user ->

Dialog says "Are you sure you wish to delete this user?"

click -> "Ok"

Receive this error:

MyBB has experienced an internal SQL error and cannot continue.
SQL Error:1054 - Unknown column 'uid' in 'where clause'
QueryBig GrinELETE FROM mybb_moderators WHERE uid='425'

url: (I removed actual path and substituted foo.bar/admin)
http://foo.bar/admin/index.php?module=us...f9c7eed09b
-------------------------------------------------------------------------------
Any suggestions as to why this error is appearing and what to do to fix it to permit deleting users (100% spam users).
Thanks,
adamf7


#2
Solved: 10 Years, 2 Months ago
Looks like you've not followed all the instructions; either you've still got 1.4 code running, or you left a 1.4 plugin active. Go to ACP > Tools & Maintenance > File Verification > does it say any files are changed??
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
#3
Solved: 10 Years, 2 Months ago
(2011-03-03, 12:35 PM)MattRogowski Wrote: Looks like you've not followed all the instructions; either you've still got 1.4 code running, or you left a 1.4 plugin active. Go to ACP > Tools & Maintenance > File Verification > does it say any files are changed??

I do not see "File Verification" you indicate in your path above when I go to ACP > Tools & Maintenance.

There are some files under UTF-8 conversion that are listed as "X-convert now"

adamf7
#4
Solved: 10 Years, 2 Months ago
It's under 'Optimize Database' in the menu on the left. If it's not there, you've not upgraded properly.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
#5
Solved: 10 Years, 2 Months ago
(2011-03-03, 02:19 PM)MattRogowski Wrote: It's under 'Optimize Database' in the menu on the left. If it's not there, you've not upgraded properly.

I guess I have not upgraded properly since I see under 'Optimize Database' :

"Table Selection
You may select the database tables you wish to perform this action on here. Hold down CTRL to select multiple tables.

Select All
Deselect All
Select Forum Tables"

Do you recomend I upgrade from the old version again? I kept notes of the upgrade and I followed the instructions when comparing the notes to the upgrade instructions. Any ideas as to where I might have not upgraded properly?

Thanks,
adamf7
#6
Solved: 10 Years, 2 Months ago
No you're not looking in the right place Undecided It's under 'Optimize Database' in the menu on the left, which is what I said above...
   
If you do not see this, you have not upgraded properly. Download 1.6.2 again, and upload the contents of the Upload folder again, and make sure the files overwrite your current files.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
#7
Solved: 10 Years, 2 Months ago
(2011-03-03, 02:43 PM)MattRogowski Wrote: No you're not looking in the right place Undecided It's under 'Optimize Database' in the menu on the left, which is what I said above...

If you do not see this, you have not upgraded properly. Download 1.6.2 again, and upload the contents of the Upload folder again, and make sure the files overwrite your current files.

Okay. I don't see that. That was simple Smile
What you say above I want to be clear on so I can keep off of here and not bother you.

Do I restore my 1.4.1 directoy and my 1.41 database (using the mysql dump I took) and then go through the upgrade again?

Thanks!
adamf7
#8
Solved: 10 Years, 2 Months ago
Do, you don't need to do any of that, you just need to upload the files again. If you've renamed your admin folder, make sure the files in the 'admin' folder in the download go into your renamed admin folder. That might be what's happened here.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
#9
Solved: 10 Years, 2 Months ago
(2011-03-03, 02:51 PM)MattRogowski Wrote: Do, you don't need to do any of that, you just need to upload the files again. If you've renamed your admin folder, make sure the files in the 'admin' folder in the download go into your renamed admin folder. That might be what's happened here.

Good catch! Lightbulb That sounds very plausible. Thanks again. Big Grin

adamf7



#10
Solved: 10 Years, 2 Months ago
(2011-03-03, 02:51 PM)MattRogowski Wrote: Do, you don't need to do any of that, you just need to upload the files again. If you've renamed your admin folder, make sure the files in the 'admin' folder in the download go into your renamed admin folder. That might be what's happened here.

The renamed adminsuper folder is what got me.... copied the files from admin to adminsuper and was good to go. Confused
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)