Jump to the post that solved this thread.
Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 9 Years, 10 Months, 3 Weeks ago Need Admin Help, or Advanced Users Only!
#1
Solved: 9 Years, 10 Months, 3 Weeks ago Exclamation 
Hello everyone,

I am an avid MyBB user, honestly I think this is one of the best forum software I've ever used. So simple, fun, and easy of use really helps my mods and guests.

I have two small problems that I was up till 5am trying to fix and for the life of me I can not figure it out Sad

Here is was I need help with:

1) When being a mod or admin there is a postbit_spam.gif image under every post in the postbit, and there should be a title="{$lang->postbit_spam}" to give you the effect when you scroll over my custom .gif for spam it will say "Mark as Spam" just like the rest of those images next to it.

I basically just need to know where to change the code because it seems this was left out. PS When I add the above code it still wont work (when added to the askmi.php plugin where I thought I should add it.

2) When a new user registers in my forums, they have to wait what seems like a long time till they receive the activation email which i require. I changed the Mass Mail Task to every 10 min, is that how I speed up the sending process? Or is there another setting in MyBB or on my server for cron jobs by chance?



If you do not understand what I mean please let me know, this is why I was asking for Admin, or Pro User help cause I need someone more advanced in PHP than myself I guess haha.

Thanks in advance for the help and you time Big Grin

-AtrixDude420
#2
Solved: 9 Years, 10 Months, 3 Weeks ago
1. Spam button appears when Akismet plugin is installed. If you want to edit the button then its in: ACP > Templates > Global Templates > akismet_postbit_spam

2. Sending Mails may depend on your host. If you are using PHP mail, try using SMTP. If you don't know how to configure SMTP let me know.
#3
Solved: 9 Years, 10 Months, 3 Weeks ago
For #1, edit the templates via the ACP:

ACP->Templates & Style->Templates->Global Templates->akismet_postbit_spam

Replace this template with:

<a href="{$mybb->settings['bburl']}/moderation.php?action=mark_as_spam&amp;pid={$post['pid']}&amp;fid={$post['fid']}"><img src="{$theme['imglangdir']}/postbit_spam.gif" alt="{$lang->spam}" title="{$lang->spam}" /></a>

For issue #2, I'm not entirely sure. There will be a natural delay no matter what (email isn't exactly "instant"). Reducing the task run time might help, but I'm not sure that activation emails run as a task - you could check the task logs to see. ACP->Tools & Maintenance->Task Manager->View Task Logs.



EDIT: darn, yaldaram beat me to it >.>
#4
Solved: 9 Years, 10 Months, 3 Weeks ago
Ok great I knew that had to do with it, just wanted someone to verify that for me.... here is the weird part though... I have it installed but not active on my forum... so why is it there? it seems to be working too sooo im stumped haha

I will try activating it and adding the code I made for the title, hopefully it works then.

As for the activation email, I am not sure if I am using PHP Mail or SMTP... I think it is PHP. How would I check this? How would I try changing it to SMTP?

I can make a [email protected] email for the activations. Would that possible be more reliable as opposed to the PHP Mail? Any experience using SMTP instead of PHP?

Thanks so much for the replies guys Big Grin
#5
Solved: 9 Years, 10 Months, 3 Weeks ago
1) That's odd that the button displays if the plugin isn't activated. I'm fairly sure it shouldn't.

2) It's likely PHP's (it is by default). You can change it in ACP->Configuration->Mail Settings. You then just fill in all the fields with the details of your SMTP mail. It may be more reliable, but there's always the possibility that it's just your mail server being slow to respond to sendmail requests. I don't personally have any experience of using SMTP myself, so I'm afraid I can't be of any help.
#6
Solved: 9 Years, 10 Months, 3 Weeks ago
Ok great I fixed #1 No problem at all just didnt know where to find that file thank you so much Yaldaram & euantor

+rep both of you

Now i just need to speed up activation mail. Any help would be appreciated! Big Grin Thanks again

-Atrixdude420
#7
Solved: 9 Years, 10 Months, 3 Weeks ago
MyBB sends activation emails immediately, if they're being delayed you'll need to contact your host to find out why.
#8
Solved: 9 Years, 10 Months, 3 Weeks ago
SMTP is almost always better than PHP mail, make the change then tell us if you're still experiencing problems.
--Pyridine
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)