Not Solved EzIRC Error
#1
Not Solved
Hi everyone again Smile

EzIRC is a plugin for mybb.
You have a plugin .php file & a 'chat.php' file you need to put in the forum root folder.

This is the 'chat.php' content :
http://pastebin.com/NQKH6na2

Now I added the chat.php into a subfolder with the name WebIRC
so mysite.com/WebIRC/chat.php

I get this error :
Warning: require_once(.//global.php) [function.require-once]: failed to open stream: No such file or directory in /home/nanogame/public_html/sergemorel/WebIRC/chat.php on line 45

Fatal error: require_once() [function.require]: Failed opening required './/global.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/nanogame/public_html/sergemorel/WebIRC/chat.php on line 45

I tried to look what's wrong , but I don't find the error, it worked before.

ALSO, it doesn't work if I put the chat.php in the root folder, I get the same error

Thanks in advance
Reply
#2
Not Solved
see above problem AND its required changes here : EzIRC for MyBB (look through first 2 pages)
Reply
#3
Not Solved
I tried to change the forumdir
I tried to put in /WebIRC
/WebIRC/
WebIRC
WebIRC/
Nothing

They all give an error that the forumdir is incorrect, if I put / it's working but with the error
Reply
#4
Not Solved
if you have chat.php in webirc folder then in chat.php put $forumdir = "../"; (on line 11)
Reply
#5
Not Solved
thanks, that works Smile
Reply
#6
Not Solved
what do you put where the * is?
$forumdir = "*"; // change this if you want the script to work outside your forums..
it was
$forumdir = "/"; // change this if you want the script to work outside your forums..
Reply
#7
Not Solved
^ depends on where you have kept chat.php file .

if chat.php is in a directory on the forum root then
$forumdir = "../";


if chat.php is in the forum root directory then
$forumdir = "/";




Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)