MyBB Community Forums

Full Version: Merge forum structure from 1.6.5 to 1.8.4
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello MyBB,
I made a forum based on 1.6.5, where I spent a lot of time making its structure (subforums, etc) and posting some important Sticky threads (all made with the Administrator user)
Because of some problems encountered with the 1.6.5, i decided to install a new board based on 1.8.4.
Now I wonder if I can move the forum structure from the old installation to the newest one.

There are the links of the two iboards:
Oldest one (1.6.5) here.
Newest one (1.8.4) here.

Thanks for your assistance.

P.S.: I tried importing some database tables from one forum to another without success. As a result, the board doesn't display any forum. These tables were:

you should be able to easily upgrade your forum from MyBB version 1.6.5 to 1.8.4
Ok, i tried upgrading the board. It worked fine (thanks for making easy and fast upgrading tools), but the fact is that the old board has a problem, which I referred here
Now, after upgrade, it shows:

Quote:MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
2006 - MySQL server has gone away
INSERT INTO mybb_threads (fid,subject,prefix,icon,uid,username,dateline,lastpost,lastposter,views,replies,visible,notes) VALUES ('86','Studiare con YouMath!','0','0','3','Neeque','1431880328','1431880328','Neeque','0','0','1','')

The new board I've installed by full installation works fine. For that, I used a new database. So I think the problem is in the database.

Now, the only solution I thought is importing the correct tables in some way from the old database...
you can try using MyBB Merge system to merge 1.8.x upgraded database with the newly setup 1.8.x forum
It seems to have worked fine, I can see all the forums and subforums and edit them in the Admin Control Panel.
The problem is: when I click on a forum, it says "404 not found", as like it didn't really recovered it.
What's happening?

Re-link of the forum after merge:

link to the merge directory:

I rebuilt all the cache and recounted all
^ disable SEF URLs from admin panel settings or rename htaccess.txt in the forum root folder (taverna) as .htaccess

admin panel >> configuration (settings) >> Server and Optimization Options >> Enable search engine friendly URLs?
It's all ok now!

I wish to thank you for your very kind and prompt support, and for developing a so complete application.