MyBB Community Forums

Full Version: Mass Email not sending.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I can not get the mybb to send any mass emails at all, Registration emails are working,
I just can not send any Mass Emails or any email through users profile email,

I have tried a few different settings and nothing, I have the forums email account setup on my windows live mail program and its working with no problem.

I'm getting no errors in the "System Email Log"

The "Mass Mailing Archive" status that the emails are Delivered

Does anyone know how to fix this ? Angry
Are you using PHP mail or SMTP?
I'm using SMTP
yeah I can't get it to work Sad
anyone know how to get the emails working ?
Is the mass mail task enabled?

Does whatever SMTP server your using have any sort of rate-limiting?
mass mail task is enable

I don't think there is any rate-limit on it because I use it through my windows live mail program with out any problems and also when I'm sending the mass email I'm testing it sending an email to 1 or 2 members to see if its working.
hello everybody, I have the same problem with mass email.
I have put on my server a file phptestmail.php, and messaghes was delivered.

I have to use a smtp server. On email ogs I see this message:
"Unable to connect to the mail server with the given details. Reason: 0: php_network_getaddresses: getaddrinfo failed: Name or service not known"
If your smtp server needs tls, check if you PHP has the openssl library (Tools & maintenance => View PHP Info).
Hi, thank for your reply. This is the php configuration I read:

System Linux 3.10.0-862.2.3.el7.x86_64 #1 SMP Wed May 9 18:05:47 UTC 2018 x86_64
Build Date Sep 6 2019 09:08:58
Configure Command './configure' '--prefix=/php7.2' '--with-libdir=lib64' '--with-mysqli' '--enable-soap' '--with-jpeg-dir=/usr' '--enable-zip' '--with-libzip=/usr' '--with-zlib-dir=/usr' '--with-png-dir=/usr' '--with-config-file-path=/etc/apache/php7.2/' '--with-config-file-scan-dir=/web/htdocs/website/php.d' '--with-gd' '--with-xmlrpc' '--with-xpm-dir=/usr' '--with-webp-dir=/usr' '--enable-gd-jis-conv' '--disable-debug' '--enable-inline-optimization' '--with-kerberos' '--with-imap' '--with-openssl' '--with-imap-ssl' '--with-mcrypt' '--enable-ftp' '--with-xsl' '--with-tidy' '--with-freetype-dir=/usr/include/freetype2/freetype/' '--with-gettext' '--enable-exif' '--enable-bcmath' '--enable-calendar' '--with-bz2' '--with-mhash' '--with-curl=/usr/local' '--enable-wddx' '--disable-ipv6' '--enable-static=mysqli' '--with-pdo-mysql' '--enable-mbstring' '--enable-intl' '--disable-maintainer-zts'
Server API CGI/FastCGI
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/apache/php7.2/
Loaded Configuration File /etc/apache/php7.2/php.ini
Scan this dir for additional .ini files /web/htdocs/website/php.d
Additional .ini files parsed (none)
PHP API 20170718
PHP Extension 20170718
Zend Extension 320170718

I think ssl/tsl are enabled -----> enable-inline-optimization' '--with-kerberos' '--with-imap' '--with-openssl' '--with-imap-ssl'