MyBB Community Forums

Full Version: Odd Error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
"Can not upload file - Too large for php post_max_size directive. Please press the back button."
I am currently getting this error when trying to post a new thread.

http://sparrownetwork.us/ if needed.

Thank you!
your question has been asked a more than a few times, try looking at this. Answers on google
(09-10-2017, 10:21 PM)Michael2014 Wrote: [ -> ]your question has been asked a more than a few times, try looking at this. Answers on google

The answers on Google often point to a php.ini upload limit/max_post size limit. None of the answers point to an issue on the actual board software.

I am experiencing a similar issue. My max post size directives are set to 128mb each.
php_value upload_max_filesize 128M
php_value post_max_size 128M
php_value max_execution_time 600
php_value max_input_time 600

I also have these set in the .htaccess within the home directory of the forum software. All of my chmod settings are correct as per the board software and the files actually upload, I just see the error, every time i upload an attachment regardless of the size.

On this particular server I also have several instances of Owncloud, which i have uploaded files in excess of 500mb without any problems. I can upload via webdav, or via the owncloud desktop application in those home folders.

So it doesn't appear to be a server issue, since this error issue is specific to the mybb forum and the files actually upload. I have a link for phpinfo if my settings need to be verified.


i am running 1.8.15 of the forum software. I was running 1.8.12 but due to this issue I upgraded the software.
As of yesterday the issue with youtube not displaying was still in the 1.8.15 download.zip so I got the updated class_parser.php file from the guithub repository. I posted a correction for this yesterday, but I don't know if it's been acted upon.

thanks very much for your time.
We override it a bit!

ACP => Configuration => Attachment Types

Note that for each attachment type you can specify a "maximum size". You can upload the smaller of this "maximum size" or the post_max_size directive in your php.ini file.
(06-14-2018, 07:04 PM)laie_techie Wrote: [ -> ]We override it a bit!

ACP => Configuration => Attachment Types

Note that for each attachment type you can specify a "maximum size". You can upload the smaller of this "maximum size" or the post_max_size directive in your php.ini file.

Yup... totally get that...

pdf is set in attachment as 20mb i uploaded a 1.7 mb pdf... no problem... I click insert to post... post get "attachment 20 or whatever.... click update post and boom.. error page...


Can not upload file - Too large for php post_max_size directive. Please press the back button.

This is after the file has been uploaded and only when you  click post reply or update post after a full edit... The file is uploaded though and appears in the post.. we just keep seeing the error page....

This looks like the edit is similar to the empty post error bug #3044
We have seen that the edit function is triggering this on update..... or when there is a new post..or a full reply..
(06-14-2018, 08:09 PM)v3_exceed Wrote: [ -> ]
(06-14-2018, 07:04 PM)laie_techie Wrote: [ -> ]We override it a bit!

ACP => Configuration => Attachment Types

Note that for each attachment type you can specify a "maximum size". You can upload the smaller of this "maximum size" or the post_max_size directive in your php.ini file.

Yup... totally get that...

pdf is set in attachment as 20mb i uploaded a 1.7 mb pdf... no problem... I click insert to post... post get "attachment 20 or whatever.... click update post and boom.. error page...


Can not upload file - Too large for php post_max_size directive. Please press the back button.

This is after the file has been uploaded and only when you  click post reply or update post after a full edit... The file is uploaded though and appears in the post.. we just keep seeing the error page....

This looks like the edit is similar to the empty post error bug #3044
We have seen that the edit function is triggering this on update..... or when there is a new post..or a full reply..

A 20 MB PDF attachment? A lot of that has to do with your settings that laie_techie mentioned.

Also... you must check with your hosting company to see how much space you have allocated for your website. 
If you upload a bunch of large files... your hosting company may not like it and will cause issues.

Please do check with your hosting company regarding the data/file transfer limitations.
(06-14-2018, 09:45 PM)Serpius Wrote: [ -> ]
(06-14-2018, 08:09 PM)v3_exceed Wrote: [ -> ]
(06-14-2018, 07:04 PM)laie_techie Wrote: [ -> ]We override it a bit!

ACP => Configuration => Attachment Types

Note that for each attachment type you can specify a "maximum size". You can upload the smaller of this "maximum size" or the post_max_size directive in your php.ini file.

Yup... totally get that...

pdf is set in attachment as 20mb i uploaded a 1.7 mb pdf... no problem... I click insert to post... post get "attachment 20 or whatever.... click update post and boom.. error page...


Can not upload file - Too large for php post_max_size directive. Please press the back button.

This is after the file has been uploaded and only when you  click post reply or update post after a full edit... The file is uploaded though and appears in the post.. we just keep seeing the error page....

This looks like the edit is similar to the empty post error bug #3044
We have seen that the edit function is triggering this on update..... or when there is a new post..or a full reply..

A 20 MB PDF attachment? A lot of that has to do with your settings that laie_techie mentioned.

Also... you must check with your hosting company to see how much space you have allocated for your website. 
If you upload a bunch of large files... your hosting company may not like it and will cause issues.

Please do check with your hosting company regarding the data/file transfer limitations.

Hi, thanks for your input, but I don't think you actually read what I wrote.

I have several owncloud installations on that server and have uploaded far larger files that a 1.7mb pdf.
In addition, i mentioned the FILES are already uploaded before the error shows up. So not a space or hosting limitation.

The php error pertaining to max_upload_size or max post size would appear before the file was uploaded or during the upload process, not after the upload has completed.

I have uploaded over 500 mb files via webdav, and no problem. I set the pdf uploads in the admin Control panel to 20 mb, (just to make sure it was far beyond the limitations) then I uploaded a 1.7 mb pdf.. one point seven mb pdf... the pdf file successfully uploads. Then, after the file has uploaded, when i select update post, I get the error..

Then, upon reviewing the thread that I posted to, the post has the attachments.
We just keep seeing the error but the file uploads because we see it in the thread afterwards. there is no reason that the error shows up at this point.

If it were a hosting error, we would see an error to the effect that we have exceeded our storage space. If it were a server error, then setting the max upload size to 128mb would have resolved this.

as previously pointed out.....

php_value upload_max_filesize 128M
php_value post_max_size 128M
php_value max_execution_time 600
php_value max_input_time 600

So it's not a server error, it is not a hosting error.. this is on a 50gb vps I have setup on one of my static IP's

For backgrounds sake, I have run a hosting company since 1998. We have had our IP  block since 1994. This is our 20th year incorporated and this forum is simply a hobby for me at this point.

I don't mean to sound like I don't appreciate the help, but you suggestion that this is a hosting issue does not make any sense given the information I have already provided. The setting laie_techie mentioned was that file type size limitation in the admin cp should be in excess of the size of file i am uploading.. So if I have 128mb flle uploads and i have set the admin cp to accept up to 20mb pdf files, then a 1.7 mb pdf that successfully uploads should not then provide an error that the file is to large for the php post size. Especially since the file had already uploaded.

For me and anyone else who is having this issue, I am looking to determine why this is happening, how to turn this error off since it isn't even the right error for this particular action.
(06-14-2018, 10:36 PM)v3_exceed Wrote: [ -> ]
(06-14-2018, 09:45 PM)Serpius Wrote: [ -> ]
(06-14-2018, 08:09 PM)v3_exceed Wrote: [ -> ]
(06-14-2018, 07:04 PM)laie_techie Wrote: [ -> ]We override it a bit!

ACP => Configuration => Attachment Types

Note that for each attachment type you can specify a "maximum size". You can upload the smaller of this "maximum size" or the post_max_size directive in your php.ini file.

Yup... totally get that...

pdf is set in attachment as 20mb i uploaded a 1.7 mb pdf... no problem... I click insert to post... post get "attachment 20 or whatever.... click update post and boom.. error page...


Can not upload file - Too large for php post_max_size directive. Please press the back button.

This is after the file has been uploaded and only when you  click post reply or update post after a full edit... The file is uploaded though and appears in the post.. we just keep seeing the error page....

This looks like the edit is similar to the empty post error bug #3044
We have seen that the edit function is triggering this on update..... or when there is a new post..or a full reply..

A 20 MB PDF attachment? A lot of that has to do with your settings that laie_techie mentioned.

Also... you must check with your hosting company to see how much space you have allocated for your website. 
If you upload a bunch of large files... your hosting company may not like it and will cause issues.

Please do check with your hosting company regarding the data/file transfer limitations.

Hi, thanks for your input, but I don't think you actually read what I wrote.

I have several owncloud installations on that server and have uploaded far larger files that a 1.7mb pdf.
In addition, i mentioned the FILES are already uploaded before the error shows up. So not a space or hosting limitation.

The php error pertaining to max_upload_size or max post size would appear before the file was uploaded or during the upload process, not after the upload has completed.

I have uploaded over 500 mb files via webdav, and no problem. I set the pdf uploads in the admin Control panel to 20 mb, (just to make sure it was far beyond the limitations) then I uploaded a 1.7 mb pdf.. one point seven mb pdf... the pdf file successfully uploads. Then, after the file has uploaded, when i select update post, I get the error..

Then, upon reviewing the thread that I posted to, the post has the attachments.
We just keep seeing the error but the file uploads because we see it in the thread afterwards. there is no reason that the error shows up at this point.

If it were a hosting error, we would see an error to the effect that we have exceeded our storage space. If it were a server error, then setting the max upload size to 128mb would have resolved this.

as previously pointed out.....

php_value upload_max_filesize 128M
php_value post_max_size 128M
php_value max_execution_time 600
php_value max_input_time 600

So it's not a server error, it is not a hosting error.. this is on a 50gb vps I have setup on one of my static IP's

For backgrounds sake, I have run a hosting company since 1998. We have had our IP  block since 1994. This is our 20th year incorporated and this forum is simply a hobby for me at this point.

I don't mean to sound like I don't appreciate the help, but you suggestion that this is a hosting issue does not make any sense given the information I have already provided. The setting laie_techie mentioned was that file type size limitation in the admin cp should be in excess of the size of file i am uploading.. So if I have 128mb flle uploads and i have set the admin cp to accept up to 20mb pdf files, then a 1.7 mb pdf that successfully uploads should not then provide an error that the file is to large for the php post size. Especially since the file had already uploaded.

For me and anyone else who is having this issue, I am looking to determine why this is happening, how to turn this error off since it isn't even the right error for this particular action.

At the time of my response, you didn't clearly state what your issue really was.

Some of us have to make a few assumptions (incorrect or not) based on your original post. 

Now that you have clarified your issue, someone else can assist you better.
Simply put I still don’t believe this is a MyBB issue. I’d suggest trying to create a php.ini file in your root directly and override your server php.ini limits. Even then, it could be that the host above you (unless your a DC which I doubt) has set hard limits which filter down to your server. I’d suggest also checking your memory_limit in PHP as this can also affect larger uploads.

On another note, MyBB doesn’t hard-limit upload sizes, so yes, ultimately this is a hosting issue.

Edit: A quick test you can do is porting your files and database over to a different host temporarily and see if this issue still occurs.
(06-15-2018, 11:24 AM)Wires Wrote: [ -> ]Simply put I still don’t believe this is a MyBB issue. I’d suggest trying to create a php.ini file in your root directly and override your server php.ini limits. Even then, it could be that the host above you (unless your a DC which I doubt) has set hard limits which filter down to your server. I’d suggest also checking your memory_limit in PHP as this can also affect larger uploads.

On another note, MyBB doesn’t hard-limit upload sizes, so yes, ultimately this is a hosting issue.

Edit: A quick test you can do is porting your files and database over to a different host temporarily and see if this issue still occurs.

At least someone is on a similar wavelength as I am regarding this issue. 

Unless there is some weird configuration that the original poster is using, it has to be related to the website host.
Pages: 1 2