MyBB Community Forums

Full Version: Awaiting Activation only for Admin Activations?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I'm just testing a 1.8 setup, and I noticed the option to do both email confirmation & admin activation, which is great, that's how I have it on a vBulletin setup.

But is there a way to remove users pending email confirmation from the awaiting activation notification?

If we proceed with MyBB 1.8, we want the process to be:

- User registers
- Confirms Email
- Admins reviews & activates user

So the alert showing prematurely is inconvenient.

Thanks
(03-25-2019, 09:29 AM)weBex Wrote: [ -> ]I'm just testing a 1.8 setup, and I noticed the option to do both email confirmation & admin activation, which is great, that's how I have it on a vBulletin setup.

But is there a way to remove users pending email confirmation from the awaiting activation notification?

If we proceed with MyBB 1.8, we want the process to be:

- User registers
- Confirms Email
- Admins reviews & activates user

So the alert showing prematurely is inconvenient.

Thanks

Yes, that is exactly how I have it set up on my website.

Once the user is activated, he/she is moved to the appropriate user group and will be out of the 'awaiting notification' status.

it's just a matter of setting up the proper email accounts in your AdminCP to do this.
Right, so... how can it be changed?
(03-25-2019, 10:32 AM)weBex Wrote: [ -> ]Right, so... how can it be changed?

For starters... go here in the AdminCP and input all of your email stuff.

[Image: 52f7984a729ec2d5ac6c8d789138c5a0.png]

Then go here... Select the 'Send Email Activation' in the Registration Method to make this work.
All other options are up to you, but this is how I have mine set up.

[Image: 11ce34c49d39b5e4ba14725edbaff21c.png]
That doesn't sound exactly what I'm trying to accomplish.

I want activations to occur both via Email & Admin approval. I want the Admin Approval to display a notification on the main board. I just don't want it do that for users in the email activation phase.
(03-25-2019, 11:01 AM)weBex Wrote: [ -> ]That doesn't sound exactly what I'm trying to accomplish.

I want activations to occur both via Email & Admin approval. I want the Admin Approval to display a notification on the main board. I just don't want it do that for users in the email activation phase.

Aha...

If you had clicked on the dropdown arrow you would have seen this highlighted option as shown.

[Image: e199083aa3915f6e50602a8a1fcd8467.png]
(03-25-2019, 11:07 AM)Serpius Wrote: [ -> ]
(03-25-2019, 11:01 AM)weBex Wrote: [ -> ]That doesn't sound exactly what I'm trying to accomplish.

I want activations to occur both via Email & Admin approval. I want the Admin Approval to display a notification on the main board. I just don't want it do that for users in the email activation phase.

Aha...

If you had clicked on the dropdown arrow you would have seen this highlighted option as shown.

[Image: e199083aa3915f6e50602a8a1fcd8467.png]

Right, I did click that, set it, and tested it before making this thread.

When that option is set, this is what happens:

User 1 & 2 registers.
User 1 activates email. User 2 does not.

A board notification says 2 users are awaiting activation - it should only be the 1; the one awaiting the Admin Activation. NOT the Email. That's the part I'm trying to accomplish.
(03-25-2019, 11:17 AM)weBex Wrote: [ -> ]Right, I did click that, set it, and tested it before making this thread.

When that option is set, this is what happens:

User 1 & 2 registers.
User 1 activates email. User 2 does not.

A board notification says 2 users are awaiting activation - it should only be the 1; the one awaiting the Admin Activation. NOT the Email. That's the part I'm trying to accomplish.

Well, obviously something is amiss here. I'm sure someone else will be able to provide further assistance for you.

While you are waiting... did you by chance look at this? 

Look at the message ID handler thingy. When I set that option to Yes, it greatly reduced the 'Awaiting Activation' list for me.

Oh yea, look at the Email Logs in the Tools & Maintenance, too. It might give you some clues.

Something for you to look into.

[Image: 2e833d360868685ff1397f6f463d6ada.png]
I tested that, and it did nothing. It doesn't sound like we're on the same page here, so I'll share these screenshots:

[Image: PXpzDIF.jpg]

[Image: f0iGw1W.jpg]
(03-25-2019, 11:37 AM)weBex Wrote: [ -> ]I tested that, and it did nothing. It doesn't sound like we're on the same page here, so I'll share these screenshots:

[Image: PXpzDIF.jpg]

[Image: f0iGw1W.jpg]

Ok, I have to ask the obvious question... this Test-User3, did you use a REAL email service? Like GMail? 

If you did use the email like... [email protected] or something like that... it won't work. MyBB relies on REAL email service. 

Now, if you had already created a GMail account or whichever is your favorite email service, then you can use something like [email protected], then it will work. (that is assuming you already have created that email account in GMail prior to doing this testing)

That second Test-User, that is correct to show that in the Manage Awaiting Activation window, if that option was chosen to be activated by the Admin.
Pages: 1 2