MyBB Community Forums

Full Version: Discord Webhooks for MyBB - Suffix Not Working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I have the Discord Webhooks for MyBB intalled. I've had it installed since early 2020 and it works fine.

However, when I followed the steps to install a Suffix version today, it is not working. I even copied it directly from my other forum, which is working, and installed that. Still no dice.

I'm not exactly sure what is going on or what I need to do to make it work.

The working version uses 'General' prefixes to send to Discord.
The not-working Suffix version should be using the 'Mature' prefixes to send to Discord. I tried changing all the settings around, or removing any of the requirements, but it seems the Suffix version is simply adverse to working.

Any assistance would be outstanding.

I can provide a link to my website if required (not the one in my signature).

Thank you kindly :)
Could you link to the such "Suffix" documentation?
Hi Omar,

Its linked in the Github information -- Link you change the word 'suffix' to whatever you want it to be and upload it to create a multi-instance.

Quote:You can also download multi-instance version of this plugin from GitHub project page ( which allows you to use another settings and different discord webhooks.

As I said, I have it working fine on my other site (signature) but not my WiP site, despite using the exact same steps etc. Not sure why it isn't working. I did put a request in on the Github but it hasn't received any replies yet.
What is exactly not working? I mean, does it display in the plugins page? It doesn't get installed or active at all? Or is the issue found at Discord site?
It isn't working in that it isn't sending a notification through to Discord when threads that fit the settings are posted or posted in.

Its plugged in, installed, and the settings have been set up following instructions and are done right (I've set up multiple versions of the plugin on my signature site with no issues) but it is simply refusing to work on my new site.
It fails with both threads and posts? It is possible that a plugin is interfering (i.e. by triggering an error) with this plugin, which plugins differ from these in your other board?
Hi Omar! Its working now! There was an issue with a piece of the code that was causing it to no longer work;

            if (preg_match('/^\s*https?:\/\/(ptb\.)?discordapp\.com\/api\/webhooks\//i', $webhookurl) == 0) {
            if (preg_match('/^\s*https?:\/\/(ptb\.)?discord\.com\/api\/webhooks\//i', $webhookurl) == 0) {
Hi, I'm glad it was fixed. Regards Smile
Not working: Tried the solution that OP posted (Doesn't work for me)