MyBB Community Forums

Full Version: "1.5" and plugins
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I understand that odd-numbered versions are "development" or "private" versions and that even-numbered ones are the public releases. Accordingly, the 1.6 beta is numbered 1.5.

However, it seems that every plugin that advertises "1.6 compatibility" checks for "16*" in the version string; because the version is actually "1501", these checks fail and I have to hack the plugin to check for "15*". No such plugin seems to check for "15*"... is this an oversight or was this done deliberately to dissuade (non-technical) users from installing plugins on the beta release? Will this be done for the 1.8.0 public beta (if there is one)?

(This is not technically a live forum... I plan to make it live eventually but I assume Gold will be released before I can do so)
1.5 is the beta , 1.6 will be the full release.
This is beta and you shouldn't need any plugins as you shouldn't use it on a production forum Wink However when 1.6 is gold, all 1.6 plugins will work and there will be no 1.8.0 MyBB, we are skipping straight to 2.0 Wink
If you want to run plugins for 1.6 beta that bad change the internal version number from 15* to 16*. A lot easier.
It is deliberate to stop people running plugins on beta.
Thanks for the answers everyone Smile

Like I said, this is not a production forum. I know what I'm doing and will upgrade this forum (manually if I have to) before making it live. I'm just developing it with 1.6 beta instead of 1.4 stable for the time being just because I like to be able to test out new features and such.
(06-13-2010, 11:27 PM)Abwayax Wrote: [ -> ]However, it seems that every plugin that advertises "1.6 compatibility" checks for "16*" in the version string; because the version is actually "1501", these checks fail and I have to hack the plugin to check for "15*". No such plugin seems to check for "15*"...

The SVN was 16* and not changed to 15* until shortly before the public beta release; so plugins that added 1.6 compatibility beforehand based on SVN probably only check for 16*. Just add 15* yourself then.
Um... it's going to be a pain to update your development board to 1.6 final. Wink Just to let you know. So building your site with it and planning to update it to final might not be the best option. But I suppose if you want to deal with that you can.
(06-17-2010, 02:56 AM)HolyPhoenix Wrote: [ -> ]Um... it's going to be a pain to update your development board to 1.6 final. Wink Just to let you know. So building your site with it and planning to update it to final might not be the best option. But I suppose if you want to deal with that you can.

And what makes you so sure on this? It might be, might not be. You can't KNOW before hand. The only ones likely to have a clue are the developers. I would suspect it will be difficult, but no more so than upgrading from 1.4.
(06-17-2010, 05:05 AM)ralgith Wrote: [ -> ]I would suspect it will be difficult, but no more so than upgrading from 1.4.
No, the upgrade script can upgrade from MyBB 1.4 to 1.6, but not from a beta version to the final...
Pages: 1 2