Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 3 Years, 2 Months, 1 Week ago SQL error
Solved: 3 Years, 2 Months, 1 Week ago
I moved my site to another server. After that when i will make a childforum i get the next error.

SQL Error:1153 - Got a packet bigger than 'max_allowed_packet' bytes.

Query:REPLACE INTO mybb_datacache SET title='forumpermissions',cache='a:914:{i:0;i:0;i:1;a:4:{i:1;a:23:{s:3:\"pid\";s:4:\"5317\";s:3:\"fid\";s:1:\"1\";s:3:\"gid\";s:1:\"1\";s:7:\"canview\";s:1:\"1\";s:14:\"canviewthreads\";s:1:\"1\";s:21:\"canonlyviewownthreads\";s:1:\"0\";s:16:\"candlattachments\";s:1:\"0\";s:14:\"canpostthreads\";s:1:\"0\";s:13:\"canpostreplys\";s:1:\"0\";s:22:\"canonlyreplyownthreads\";s:1:\"0\";s:18:\"canpostattachments\";s:1:\"0\";s:14:\"canratethreads\";s:1:\"0\";s:12:\"caneditposts\";s:1:\"0\";s:14:\"candeleteposts\";s:1:\"0\";s:16:\"candeletethreads\";s:1:\"0\";s:18:\"caneditattachments\";s:1:\"0\";s:8:\"modposts\";s:1:\"0\";s:10:\"modthreads\";s:1:\"0\";s:14:\"mod_edit_posts\";s:1:\"0\";s:14:\"modattachments\";s:1:\"0\";s:12:\"canpostpolls\";s:1:\"0\";s:12:\"canvotepolls\";s:1:\"0\";s:9:\"cansearch\";s:1:\"0\";}i:2;a:23:{s:3:\"pid\";s:4:\"5318\";s:3:\"fid\";s:1:\"1\";s:3:\"gid\";s:1:\"2\";s:7:\"canview\";s:1:\"1\";s:14:\"canviewthreads\";s:1:\"1\";s:21:\"canonlyviewownthreads\";s:1:\"0\";s:16:\"candlattachments\";s:1:\"1\";s:14:\"canpostthreads\";s:1:\"0\";s:13:\"canpostreplys\";s:1:\"1\";s:22:\"canonlyreplyownthreads\";s:1:\"0\";s:18:\"canpostattachments\";s:1:\"1\";s:14:\"canratethreads\";s:1:\"1\";s:12:\"caneditposts\";s:1:\"1\";s:14:\"candeleteposts\";s:1:\"0\";s:16:\"candeletethreads\";s:1:\"0\";s:18:\"caneditattachments\";s:1:\"1\";s:8:\"modposts\";s:1:\"0\";s:10:\"modthreads\";s:1:\"0\";s:14:\"mod_edit_posts\";s:1:\"0\";s:14:\"modattachments\";s:1:\"0\";s:12:\"canpostpolls\";s:1:\"0\";s:12:\"canvotepolls\";s:1:\"1\";s:9:\"cansearch\";s:1:\"1\";}i:5;a:23:{s:3:\"pid\";s:4:\"5319\";s:3:\"fid\";s:1:\"1\";s:3:\"gid\";s:1:\"5\";s:7:\"canview\";s:1:\"1\";s:14:\"canviewthreads\";s:1:\"1\";s:21:\"canonlyviewownthreads\";s:1:\"0\";s:16:\"candlattachments\";s:1:\"0\";s:14:\"canpostthreads\";s:1:\"0\";s:13:\"canpostreplys\";s:1:

And much more lines
What do i have to do to resolve this.

Solved: 3 Years, 2 Months, 1 Week ago
you contact your host .

It is not disgraceful to ask, it is disgraceful no to ask.

sory for my english .
Solved: 3 Years, 2 Months, 1 Week ago
(2016-12-13, 09:17 AM)roy Wrote: you contact your host .

This. It's a host issue.
Solved: 3 Years, 2 Months, 1 Week ago
Specifically the max_allowed_packet MySQL setting is too low.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Solved: 3 Years, 2 Months, 1 Week ago
So, now i have root acces. What do i have to do?
Solved: 3 Years, 2 Months, 1 Week ago
(2016-12-17, 08:44 AM)erigo19 Wrote: So, now i have root acces. What do i have to do?
With root access SSH into the server.
Find where your my.cnf file is located, you might need to ask your host but the most common locations are:
  • /etc/my.cnf
  • /etc/mysql/my.cnf
With that information enter the command:
nano path_to_file
Replacing path_to_file with the path to my.cnf
Please Note: If your server doesn't have the nano text editor installed try using vim.

Once the file has been opened look for max_allowed_packet under the [mysqld] section.
Change the value to something higher I recommend 64M.

After you have saved the changes to the file enter this command:
/etc/init.d/mysqld restart
And you should be good to go  Blush
Solved: 3 Years, 2 Months, 1 Week ago
Problem solved, and sorry for the late respons.
Thnx infinite

Forum Jump:

Users browsing this thread: 1 Guest(s)